Issues with MoonPay App user balances

Incident Report for MoonPay

Resolved

The issue was identified and fixed.
Posted Oct 27, 2025 - 14:41 UTC

Identified

We are currently investigating an issue where some users may see incorrect or missing balance information in their MoonPay accounts.

Please note that all funds are safe and on-chain balances remain unaffected — you can verify them directly via blockchain explorers.

Our team is working to identify the cause and restore accurate balance visibility as quickly as possible. We'll provide updates as soon as we have more information.
Posted Oct 27, 2025 - 13:48 UTC
This incident affected: MoonPay App and Features (Wallet Balances).