Delays in New Customer Document Verification

Incident Report for MoonPay

Resolved

The previous delays affecting new customer document verification have been resolved. All systems are operating normally.
Posted May 22, 2025 - 10:16 UTC

Identified

We are currently experiencing delays in our document verification process for new customers. We have identified the cause and are actively working on a resolution. Existing customers are unaffected.
Posted May 22, 2025 - 09:45 UTC