We are seeing recovery from our third party providers and service is mostly restored. Functionalities which require phone number validation might experience difficulties. We'll keep monitoring.
Posted Oct 20, 2025 - 10:02 UTC
Update
We are investigating an incident affecting one or more third-party providers, resulting in intermittent errors and elevated latency across parts of our platform. Some features may be unavailable or degraded, including document verification, card payments, and crypto delivery for select currencies. We are working with the impacted providers to mitigate the issue and will share updates as we learn more.
Posted Oct 20, 2025 - 09:42 UTC
Identified
We're aware of customers facing an issue of not being able to complete a transaction using cards. We're investigating the issue.
Posted Oct 20, 2025 - 07:54 UTC
This incident affected: Payment Methods (Buy) (Credit & Debit Cards).