LTC Transactions are currently delayed

Incident Report for MoonPay

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 20:48 UTC

Monitoring

All delayed orders are now processing and will be delivered shortly, depending on the speed of the chain.
Posted Jul 01, 2025 - 20:34 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 01, 2025 - 20:29 UTC

Investigating

We are currently experiencing a delay in processing LTC transactions. We're working on identifying and resolving the issue as soon as possible.
Posted Jul 01, 2025 - 19:47 UTC
This incident affected: Digital Currencies (Litecoin).