Our Ramps are slow to load

Incident Report for MoonPay

Resolved

The issue causing MoonPay On Ramp & Off Ramp to load slowly for logged out users has been fixed. Ramps are now operating normally.
Posted May 16, 2025 - 10:53 UTC

Investigating

MoonPay On Ramp & Off Ramp are loading very slowly for logged out users. We're investigating actively.
Posted May 16, 2025 - 10:16 UTC