Transactions for some USA based customers are currently delayed

Incident Report for MoonPay

Resolved

All transactions have now been processed.
Posted Aug 17, 2025 - 00:11 UTC

Monitoring

We've implemented a fix and all orders are now being processed on chain.
Posted Aug 17, 2025 - 00:05 UTC

Identified

We've identified the root cause and are working on a remedy.
Posted Aug 17, 2025 - 00:03 UTC

Investigating

We noticed a delay in the completion of transactions in the USA. We're investigating the root cause. We'll keep you updated through this incident.
Posted Aug 16, 2025 - 23:50 UTC
This incident affected: On-ramp Widget.