Memo tag field is missing for certain tokens

Incident Report for MoonPay

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 10:46 UTC

Identified

We're currently fixing the issue and will provide an update soon.
Posted Jul 29, 2026 - 09:17 UTC

Investigating

Some tokens (like XRP) need an extra field called a Memo tag to reach the right account. We've found it's currently missing for the Widget and the App. We're investigating and will share an update soon.
Posted Jul 29, 2026 - 08:34 UTC
This incident affected: On-ramp Widget and MoonPay App.