BTC send intermittent failure

Incident Report for MoonPay

Resolved

BTC transfer functionality has been fully restored. All Bitcoin-related features, including sending and balance checks, are now operating normally.
We will continue to monitor the situation closely and take immediate action if any issues resurface.

Thank you for your continued patience and support.
Posted Apr 03, 2025 - 20:10 UTC

Monitoring

We are still experiencing intermittent issues with Bitcoin (BTC) transfers BTC balance features remain fully functional. Our team is actively monitoring the situation and working to ensure stable service.

Thank you for your understanding.
Posted Apr 03, 2025 - 20:02 UTC