Onramp & Offramp delivery of some crypto assets is delayed

Incident Report for MoonPay

Resolved

All pending orders are delivered and the issue is resolved.
Posted Apr 15, 2026 - 12:35 UTC

Update

A fix has been applied and transaction processing has resumed.
Posted Apr 15, 2026 - 12:28 UTC

Monitoring

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Apr 15, 2026 - 12:27 UTC

Identified

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Apr 15, 2026 - 12:19 UTC

Investigating

We are investigating this issue and we will provide more updates in the next few hours.
Posted Apr 15, 2026 - 12:09 UTC