Issues loading Bitcoin balances in the MoonPay app

Incident Report for MoonPay

Resolved

The balance loading issue has been resolved.
Posted Apr 15, 2025 - 09:26 UTC

Investigating

Some users are experiencing an incorrect Bitcoin wallet balance on their MoonPay app.
We're investigating the issue and expect balances to show up correctly soon.
Posted Apr 15, 2025 - 07:53 UTC
This incident affected: Products (MoonPay App).