Issues loading Balances on MoonPay app

Incident Report for MoonPay

Resolved

The issue has been fixed. Loading balances is now back to normal.
Posted Nov 06, 2025 - 14:55 UTC

Monitoring

The issue should now be fixed - all balances should load fine now. We'll keep monitoring the changes.
Posted Nov 06, 2025 - 14:15 UTC

Identified

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Nov 06, 2025 - 14:12 UTC
This incident affected: MoonPay App and Features (Wallet Balances).