Widget Load Time Extremely Slow
Incident Report for MoonPay
Resolved
This is now resolved!
Posted Jun 20, 2024 - 13:23 UTC
Investigating
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Jun 20, 2024 - 13:13 UTC