Some transactions are taking longer than expected to complete
Incident Report for MoonPay
Resolved
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Sep 05, 2024 - 12:28 UTC
Identified
We've spotted that a small number of transactions are taking longer to deliver than we expect. This should be resolved shortly.
Posted Sep 05, 2024 - 12:07 UTC