MoonPay App hanging for some users

Incident Report for MoonPay

Resolved

This issue is now resolved. Effected users will need to close and re-open their app to apply the fix.
Posted Aug 04, 2025 - 13:24 UTC

Monitoring

This has now been resolved, and we will continue to monitor. Users will have to close and re-open the App to get the latest fix.
Posted Aug 04, 2025 - 12:58 UTC

Identified

We've spotted that something has gone wrong and some users are experiencing their MoonPay App hanging when opening.

We're currently investigating the issue, and will provide an update soon.
Posted Aug 04, 2025 - 12:32 UTC
This incident affected: MoonPay App.