OnRamp unavailable for some customers

Incident Report for MoonPay

Resolved

The issue affecting our on-ramping product has now been solved. On ramping is working again.
Posted Jul 07, 2025 - 22:25 UTC

Investigating

We've spotted that something has gone wrong with our OnRamp product. We're currently investigating the issue, and will provide an update soon.
Posted Jul 07, 2025 - 22:15 UTC
This incident affected: On-ramp Widget.