Some USA based customers are facing a delay with crypto delivery

Incident Report for MoonPay

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 08:57 UTC

Monitoring

All orders have now been delivered or are on chain, ready to be delivered.
Posted Mar 28, 2025 - 08:34 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 28, 2025 - 08:26 UTC

Investigating

We're experiencing a delay in the delivery of crypto to some USA based customers. The team is investigating and we'll send an update shortly.
Posted Mar 28, 2025 - 08:13 UTC
This incident affected: On-ramp Widget.