MoonPay.com website is down
Incident Report for MoonPay
Resolved
This incident has been resolved.
Posted Aug 07, 2024 - 19:52 UTC
Monitoring
We've identified and fixed the root cause. We're actively monitoring.
Posted Aug 07, 2024 - 19:44 UTC
Investigating
MoonPay.com is experiencing an issue with our hosting provider. We're working with the provider to resolve as soon as possible. Our widget can still be accessed on buy.moonpay.com"
Posted Aug 07, 2024 - 19:34 UTC