We’ve noticed a problem with DeFi trading on Solana and are looking into it

Incident Report for MoonPay

Resolved

This incident has been resolved.
Posted Apr 17, 2025 - 03:16 UTC

Investigating

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Apr 17, 2025 - 02:54 UTC