Delayed Transactions - SOL
Incident Report for MoonPay
Resolved
This incident has been resolved.
Posted Jun 21, 2024 - 16:54 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 21, 2024 - 15:33 UTC
Investigating
We're experiencing delays with SOL transactions, we are working on a fix and we will update the status once we have further updates.
Posted Jun 21, 2024 - 15:18 UTC
This incident affected: Digital Currencies (Solana).