ETH and BTC delivery delays

Incident Report for MoonPay

Resolved

Bitcoin and Ethereum deliveries are no longer experiencing delays. The issue has been resolved.
Posted Mar 23, 2023 - 13:01 UTC

Identified

We're experiencing delivery delays for Bitcoin and Ethereum. Our team is looking into it.
Posted Mar 23, 2023 - 12:06 UTC
This incident affected: API, Features (Discovery), and Digital Currencies (Bitcoin, Ethereum).