Onramp delivery of some crypto assets is delayed

Incident Report for MoonPay

Resolved

The issue has been fixed and all pending orders are completed.
Posted May 08, 2026 - 08:29 UTC

Monitoring

The issue has been fixed and stuck orders are now processing
Posted May 08, 2026 - 08:08 UTC

Identified

We have identified an issue with an upstream service provider that is causing delays in the delivery of some crypto assets for onramp orders.
New orders are being processed through available alternatives where possible. We are actively working to resolve delays for affected pending orders and will provide another update as soon as we have more information.
Posted May 08, 2026 - 07:42 UTC

Investigating

We are currently investigating this issue.
Posted May 08, 2026 - 06:58 UTC
This incident affected: On-ramp Widget and Off-ramp Widget.