Transaction processing is delayed

Incident Report for MoonPay

Resolved

Some transaction processing was delayed due to issues with a compliance provider. We are no longer seeing delays and all affected transactions have now been processed correctly.
Posted Nov 14, 2025 - 15:08 UTC

Identified

Due to a third party issue we are experiencing some delays in transaction processing. We are investigating this issue and we will provide more updates.
Posted Nov 14, 2025 - 12:30 UTC
This incident affected: On-ramp Widget and MoonPay App.