Onramp and Offramp are unavailable for some customers

Incident Report for MoonPay

Resolved

All services and systems are now operating at the expected levels of service.
Posted Jun 12, 2025 - 20:16 UTC

Monitoring

Our Cloud provider has resolved the issue. All systems are now recovering and we're working on bringing all systems and regions back to normal. We're continuing to monitor the situation at our Cloud Hosting provider as well.
Posted Jun 12, 2025 - 19:39 UTC

Identified

The engineers of our Cloud Hosting vendor are continuing to mitigate the issue and the outage should start to recover in some locations.
Posted Jun 12, 2025 - 19:21 UTC

Update

We are continuing to investigate and work with our cloud hosting provider to resolve this issue.
Posted Jun 12, 2025 - 18:54 UTC

Update

We've escalated the issue with our cloud hosting provider and are working with them to resolve the situation as soon as we can.
Posted Jun 12, 2025 - 18:29 UTC

Update

Our cloud hosting provider is experiencing issues. We are actively investigating the problem.
Posted Jun 12, 2025 - 18:19 UTC

Investigating

We're experiencing an elevated level of API errors across all regions and are currently looking into the issue.
Posted Jun 12, 2025 - 18:17 UTC
This incident affected: API, On-ramp Widget, and Off-ramp Widget.