Some ETH transactions are currently facing a delay

Incident Report for MoonPay

Resolved

This incident has been resolved.
Posted Aug 15, 2025 - 23:15 UTC

Monitoring

The impacted transactions have now been completed on chain. We're working on also delivering all emails and the correct transaction status in our widget and the app. New transactions are not impacted.
Posted Aug 15, 2025 - 19:29 UTC

Identified

We've identified an issue with one of our external partners and are working with them to resolve the issue as soon as possible.
Posted Aug 15, 2025 - 11:49 UTC

Investigating

We are currently experiencing a delay in processing some ETH transactions. We're working on identifying and resolving the issue as soon as possible.
Posted Aug 15, 2025 - 11:33 UTC
This incident affected: Digital Currencies (Ethereum).