Onramp delivery of some crypto assets is delayed

Incident Report for MoonPay

Resolved

We have resolved the issue and normal asset delivery has resumed.
Posted Sep 12, 2025 - 17:27 UTC

Investigating

We are experiencing delays with delivering ETH to some US customers. We are investigating this issue and we will provide more updates in the next few hours.
Posted Sep 12, 2025 - 17:06 UTC