Users are unable to send BTC

Incident Report for MoonPay

Resolved

BTC transfer and balance features are now restored.
Posted Apr 03, 2025 - 19:56 UTC

Identified

Our Bitcoin (BTC) service provider is currently experiencing issues. As a result, BTC transfers and balance-related features are temporarily unavailable. We are actively monitoring the situation and will update you as soon as services are restored.

Thank you for your patience.
Posted Apr 03, 2025 - 19:50 UTC
This incident affected: Products (MoonPay App).