Issues with APIs and Widget due to Cloudflare Outage

Incident Report for MoonPay

Resolved

The incident has been resolved and all services are restored.
Posted Dec 05, 2025 - 09:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2025 - 09:15 UTC

Investigating

We're currently encountering issues with our APIs and Widget affecting Ramps due to major Cloudflare outage
Posted Dec 05, 2025 - 09:10 UTC
This incident affected: API, On-ramp Widget, Off-ramp Widget, and MoonPay App.