Delays in processing BTC

Incident Report for MoonPay

Resolved

Bitcoin (BTC) transactions are processing normally. The latency issue has been resolved.
Posted Jun 09, 2026 - 16:57 UTC

Monitoring

Bitcoin (BTC) transactions are currently processing normally. We will continue to closely monitor activity and provide updates if there are any changes.
Posted Jun 09, 2026 - 15:46 UTC

Investigating

There are some delays in processing BTC payments, the team is investigating.
Posted Jun 09, 2026 - 15:22 UTC
This incident affected: On-ramp Widget and MoonPay App.