Increased Latency for the MoonPay API

Incident Report for MoonPay

Resolved

All systems have returned to normal operation.
Posted Jul 31, 2026 - 19:49 UTC

Update

Some on-chain wallet balances for newly-created wallets may not reflect recent on-chain activity immediately. Buy, Sell, and Swap transactions are still being processed successfully.
Posted Jul 31, 2026 - 04:29 UTC

Monitoring

The issue is resolved and the MoonPay API is returning to normal operations.

Engineers continue to monitor recovery.
Posted Jul 31, 2026 - 03:45 UTC

Investigating

We are currently investigating increased latency on the MoonPay API, affecting the Buy and Sell flows, and the MoonPay App.
Posted Jul 31, 2026 - 02:57 UTC
This incident affected: API, On-ramp Widget, Off-ramp Widget, MoonPay App and Features (Wallet Balances).