Unavailability of support.moonpay.com and dev.moonpay.com

Incident Report for MoonPay

Resolved

support.moonpay.com and dev.moonpay.com are now available. This incident has been resolved.
Posted Feb 19, 2025 - 01:17 UTC

Identified

We've narrowed down the issue to an external hosting provider. For customer support, please email support@moonpay.com
Posted Feb 19, 2025 - 00:25 UTC