Elevated failure rate on swap transactions

Incident Report for MoonPay

Resolved

The issue has been resolved. All systems are now operating normally. We’ll continue to monitor to ensure stability.
Posted Apr 15, 2026 - 15:58 UTC

Identified

We are currently investigating an issue causing an increased failure rate for some swap transactions. Users may experience errors when fetching swap quotes or completing swaps.

Our team has identified multiple contributing factors and is actively working to reduce the failure rate and improve reliability.
Posted Apr 15, 2026 - 06:43 UTC
This incident affected: Features (Convert).