Some users may be facing login issues

Incident Report for MoonPay

Resolved

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Jul 15, 2025 - 11:52 UTC

Investigating

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Jul 14, 2025 - 10:04 UTC