MoonPay Support Portal unavailable

Incident Report for MoonPay

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 18:44 UTC

Update

Resolved - All systems are operating normally.
Posted Nov 19, 2025 - 18:35 UTC

Identified

We've spotted that our support portal support.moonpay.com is unavailable/slow, we've identified there is an active issue with the vendor.
Thank you for your patience whilst this issue is being resolved
Posted Nov 19, 2025 - 16:57 UTC