New users are facing an issue when entering their billing address
Incident Report for MoonPay
Resolved
This incident has been resolved.
Posted Jul 12, 2024 - 08:28 UTC
Monitoring
We've identified and fixed the root cause. We're actively monitoring.
Posted Jul 12, 2024 - 08:21 UTC
Investigating
We're aware of an issue that some customers are currently facing when trying to enter their billing address. We're actively investigating.
Posted Jul 12, 2024 - 08:00 UTC
This incident affected: On-ramp Widget and Off-ramp Widget.