Ethereum Pectra Upgrade

Incident Report for MoonPay

Resolved

The scheduled upgrade has been completed.
Posted May 07, 2025 - 11:19 UTC

Identified

Due to the Ethereum Pectra upgrade, all withdrawals and deposits for tokens on the Ethereum Mainnet chain are temporarily disabled. Full operation should resume once the upgrade is completed. The upgrade is expected to complete in a couple of hours.
Posted May 07, 2025 - 09:24 UTC