Delays in processing SEPA instant payments

Incident Report for MoonPay

Resolved

This incident has been resolved.
Posted May 20, 2026 - 06:39 UTC

Identified

Due to an unexpected issue on our provider’s side, you may experience interruptions with the SEPA Instant payment method.
Posted May 19, 2026 - 12:24 UTC
This incident affected: Payment Methods (Buy) (EUR Bank Transfers (SEPA), SEPA Open Banking Payments).