Balances in the MoonPay app are not loading

Incident Report for MoonPay

Resolved

The impact from the issue is over.
Posted May 22, 2026 - 15:34 UTC

Monitoring

We investigated the issue, deployed a fix and we're monitoring.
Posted May 22, 2026 - 15:18 UTC

Identified

Balances in the MoonPay app are not loading. We're currently investigating the issue, and will provide an update soon.
Posted May 22, 2026 - 14:49 UTC
This incident affected: MoonPay App.