Sell Transaction Delays

Incident Report for MoonPay

Resolved

Transactions are completing as normal and any delayed transactions have been processed.
Posted Oct 31, 2025 - 15:20 UTC

Update

Sell transactions are starting to process again. We are monitoring and will update once full performance is confirmed.
Posted Oct 31, 2025 - 15:09 UTC

Monitoring

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Oct 31, 2025 - 15:07 UTC

Identified

Due to an issue with a 3rd party provider we are experiencing some delays with sell transactions completing.
Posted Oct 31, 2025 - 14:47 UTC
This incident affected: API, Off-ramp Widget and Features (Discovery).