Processing of some transactions is delayed

Incident Report for MoonPay

Resolved

This incident has been resolved.
Posted Oct 17, 2025 - 16:04 UTC

Monitoring

The issue has been resolved. We're actively monitoring the situation to confirm continued stability.
Posted Oct 17, 2025 - 15:43 UTC

Identified

Some transactions are currently facing a delay. We've identified the problem and are currently working on resolving the issue.
Posted Oct 17, 2025 - 12:08 UTC
This incident affected: On-ramp Widget.