BTC Balances are not loading on the app

Incident Report for MoonPay

Resolved

BTC balances displaying on the app have been restored.
Posted Oct 20, 2025 - 22:03 UTC

Identified

We've spotted that something has gone wrong. We're currently investigating the issue while working with our balances provider, and will provide an update soon.
Posted Oct 20, 2025 - 21:35 UTC
This incident affected: MoonPay App.