MoonPay App Polygon Balances Not Loading

Incident Report for MoonPay

Resolved

This incident has been resolved.
Posted Jul 30, 2025 - 16:29 UTC

Update

We are aware of an issue with loading assets on Polygon in the MoonPay App. This does not impact any other chains.
Posted Jul 30, 2025 - 12:36 UTC

Identified

We are having issues loading all EVM compatible chain balances in the MoonPay App. We have identified the cause and are working on a fix.
Posted Jul 30, 2025 - 12:06 UTC
This incident affected: MoonPay App.