Degraded DeFi Performance on Solana

Incident Report for MoonPay

Resolved

DeFi trading on Solana is back to normal.
Posted Jul 09, 2025 - 14:53 UTC

Monitoring

The issue has been resolved and we'll currently monitoring.
Posted Jul 09, 2025 - 14:35 UTC

Update

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Jul 09, 2025 - 14:00 UTC

Investigating

We've seen degraded performance when interacting with Solana tokens. We're investigating further and will report back soon.
Posted Jul 09, 2025 - 13:59 UTC
This incident affected: Products (MoonPay App).