Delayed Transactions - Multiple Networks
Incident Report for MoonPay
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 17:37 UTC
Investigating
We are aware that some users may be experiencing a slight delay in completing transactions. Our team is investigating this issue and will provide an update shortly.
Posted Mar 15, 2024 - 16:02 UTC
This incident affected: On-ramp Widget.