Delays with BTC and SOL for USA based customers

Incident Report for MoonPay

Resolved

Full system functionality restored
Posted Feb 18, 2025 - 17:47 UTC

Identified

We experience issue with delivery of tokens to US based customers. The issue has been rectified and we are now monitoring the results.
Posted Feb 18, 2025 - 17:30 UTC

Investigating

We've identified delay in the delivery of SOL and BTC to USA based customers. The team is investigating and we'll send an update shortly
Posted Feb 18, 2025 - 16:39 UTC
This incident affected: On-ramp Widget.