App freezes while buying tokens with a memo/tag

Incident Report for MoonPay

Resolved

The issue is now fixed 🎃
Posted Oct 31, 2025 - 17:36 UTC

Identified

We detected the issue and are now deploying a fix.
Posted Oct 31, 2025 - 17:09 UTC

Investigating

We've spotted the App freezes when buying tokens that support a memo tag. We're currently investigating the issue, and will provide an update soon. You can use buy.moonpay.com in the meantime.
Posted Oct 31, 2025 - 16:59 UTC
This incident affected: MoonPay App.