Issues affecting login to MoonPay

Incident Report for MoonPay

Resolved

This issue is now resolved.
Posted Oct 22, 2025 - 01:48 UTC

Identified

We're resolving an issue affecting the ability to log into Moonpay
Posted Oct 22, 2025 - 01:33 UTC
This incident affected: MoonPay App.