Issues loading EVM balances in the MoonPay app

Incident Report for MoonPay

Resolved

All EVM balances should show correctly now.
Posted May 26, 2025 - 16:18 UTC

Identified

Some users may experience issues loading their MoonPay wallet balances on EVM (Ethereum, Polygon, etc.) blockchains.
Posted May 26, 2025 - 15:43 UTC
This incident affected: Products (MoonPay App).