Elevated API Errors

Incident Report for MoonPay

Resolved

The issue has now been resolved.
Posted Nov 21, 2025 - 05:07 UTC

Monitoring

Normal asset delivery has resumed, we'll continue monitor until the issue is resolved.
Posted Nov 21, 2025 - 05:03 UTC

Investigating

We are experiencing delays with delivering ETH to some US customers. We are investigating this issue and we will provide more updates in the next few hours.
Posted Nov 21, 2025 - 04:27 UTC
This incident affected: API and Features (Discovery).