On and Offramp delivery of crypto assets are delayed

Incident Report for MoonPay

Resolved

All systems are operating normally.
Posted Nov 18, 2025 - 15:07 UTC

Update

We have detected and mitigated an issue affecting users' ability to log in to MoonPay. Transaction processing remains stable.
Posted Nov 18, 2025 - 14:21 UTC

Monitoring

We are seeing services recovering and withdrawals are now processing - we are actively monitoring the situation and will provide another update shortly.
Posted Nov 18, 2025 - 12:20 UTC

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 12:14 UTC

Investigating

We are experiencing issues with some of MoonPay services. Following are impacted
* Inbound and OutBound transaction processing
* Some balances may be displayed incorrectly
* Some payment methods are impacted

We are actively investigating this and we will provide a new update as soon as possible.
Posted Nov 18, 2025 - 11:59 UTC
This incident affected: API, On-ramp Widget, Off-ramp Widget, and MoonPay App.