Delays processing Apple Pay payments

Incident Report for MoonPay

Resolved

This incident has been resolved.
Posted May 06, 2026 - 13:04 UTC

Monitoring

We deployed a fix that reduced the number of affected users. We’re continuing to monitor the situation and will apply further fixes if needed.
Posted May 06, 2026 - 11:54 UTC

Identified

We identified an issue with payments using Apple Pay, which are taking too long for some users. We're currently fixing the issue, and will provide an update soon.
Posted May 06, 2026 - 10:54 UTC

Investigating

We've that payments with Apple Pay and taking longer than expected for some users. We're currently investigating the issue, and will provide an update soon.
Posted May 06, 2026 - 10:47 UTC
This incident affected: Payment Methods (Buy) (Apple Pay).